LSB 5.0 Beta 1

The LSB workgroup is pleased to announce the availability of LSB 5.0 Beta 1.

This beta is intended to test the completeness of our data gathering for this release, and consists of the LSB SDK and the application and distribution checkers. We are releasing these items for the x86 and x86_64 platforms first.

The SDK, Application Checker, and Distribution Checker can be downloaded from the Linux Foundation's FTP site:

http://ftp.linuxfoundation.org/pub/lsb/bundles/beta/

The SDK and Distribution Checker can be installed by unpacking the tarball and running the 'install.sh' script contained within. The Application Checker can be unpacked and run in-place. The instructions are consistent with those for the stable SDK and test kits, available here:

For the Distribution Checker, we do not recommend that it be run on important production systems, as the distribution testing process modifies the environment in a number of ways that are undesireable. We recommend installing in a virtual machine installed for the purpose of testing.

Also, for distribution tests, the checkers are supplemented with the LSB 4.1 distribution tests. You can run just the checkers by running "Custom Tests" and selecting the "Command Check" and "Library Check" tests only. Be sure to tell the Distribution Checker to use the pre-installed versions.

Some known issues:

  • Builds of the beta on architectures other than x86 and x86_64 had some problems, which we expect to fix in time for Beta 2.
  • SDK: building for some of the new APIs, such as GTK+ 3, are still a bit unreliable.
  • LSB support in current Linux distributions will be at the 4.1 level or earlier, which may mean that some distribution checks will fail and LSB 5.0-built apps may fail to run until those missing pieces are installed.

Of course, as a beta product, there will likely be other problems. Please report any problems you encounter to the lsb-discuss list, to our bug tracker at lsbbugs.linuxfoundation.org, or to us on IRC at #lsb on Freenode.

Groups: