database/foomaticgswrapper


The Foomatic Ghostscript Wrapper

The foomatic-gs-wrapper is not needed any more in Foomatic 4.0 and therefore obsolete. This page is only available for historical reasons. Note that the script is not downloadable any more as a single file but only as part of the foomatic-rip 3.0.x tarballs or from the Foomatic 3.0.x BZR repositories.

You may want to install the foomatic-gswrapper script. This runs Ghostscript in a more controlled way, and makes debugging much easier by letting you see Ghostscript error messsages.

The wrapper is required if you print jobs from the Windows PostScript driver (which writes jobs that generate advisory output that causes trouble under plain Ghostscript). Some other software may produce such jobs; the wrapper is probably a good idea in general.

To install, save somewhere in your path as foomatic-gswrapper and mark executable with chmod 755 foomatic-gswrapper. Be sure that foomatic-rip can find foomatic-gswrapper; it might be easiest to install it in /usr/bin, which is almost always in the default path.

Report bugs on our bug tracking system, product "OpenPrinting", component "foomatic-filters".

Groups: